Invoicing Outage

Incident Report for Yona

Resolved

Invoicing has recovered and is now operational.
Posted Aug 10, 2026 - 04:14 BST

Investigating

Invoicing is currently unreachable. Our team has been notified and is investigating.
Posted Aug 10, 2026 - 04:13 BST
This incident affected: Invoicing.